info@giuseppegioe.it

Guida completa su Excel

Post Series: Microsoft Excel

Excel: gestire le intestazioni di pagina

Quando si devono realizzare report che occupano più fogli, è utile riportare in ciascuna pagina l’ordine di stampa. Per ottenere questo risultato, andare in INSERISCI e scegliere Intesta:ione e piè di pagina. Excel, dopo aver visualizzato tre riquadri che corrispondono alle zone in cui è possibile inserire i dati, attiva
la scheda PROGEITAZIONE con tutte le opzioni a disposizione. Per visualizzare il numero del foglio specifico rapportato al totale delle pagine, scegliere le opzioni Numero di pagina e Numero di pagine (a video si vedrà &[Pagina] &[Pagine]) presenti nel gruppo Elementi intestazione e piè di pagina.

Excel_set_header_footerRicordiamo che il programma può far comparire automaticamente anche il giorno e l’ora corrente, il nome del documento e un’immagine contenuta in un file. In quest’ ultimo caso, dopo aver aggiunto l’elemento grafico si ha la facoltà di effettuare delle semplici operazioni di editing tra cui il ridimensionamento, il
ritaglio e la regolazione del contrasto o della luminosità.

CALCOLI AD HOC

Excel mette a disposizione alcune funzioni per effettuare calcoli condizionati.
Avete un lungo elenco di spese e desiderate ottenere i riepiloghi per ciascuna voce? Niente di più facile affidandosi a SOMMA.SE. Questa funzione somma
i dati delle sole celle che soddisfano una determinata condizione. Nel nostro
esempio, consideriamo un foglio Excel che contiene un elenco di spese, da 813 ad 8100 sono presenti le voci di spesa (Luce, Gas, benzina e così via) e nelle corrispondenti celle di e la cifra spesa. Se si digita in una cella la formula: =SOMMA.SE(B13:8100;”LuceN”;C13:C100)
Excel inserirà la somma di tutte le celle nell’ intervallo specificato della colonna C alla cui sinistra, nella colonna B, è presente “Luce”. Ovviamente al posto di una condizione fissa è possibile inserire il riferimento alla cella che la contiene.
Per esempio, se la categoria Luce è memorizzata in B6 si può scrivere: =SOMMA.SE(B13:B100;B6;C13:C100)
Grazie invece a SOMMA.PIÙ.SE si può far dipendere la somma da più parametri. In q uesto esempio, partendo da l presupposto che A contenga l’anno dell’operazione, si può calcolare la somma raggruppata per voce e per periodo (ad esempio il 2011) digitando:
=S0mma.PIÙ.SE(C13:C100;B13:B100; TB3;A13:A100;2011)

Altre due funzioni simili sono CONTA.SE e CONTA.PIÙ.SE, le quali restituiscono il numero di celle che soddisfano le condizioni impostate, invece di elaborarne
il contenuto.

La funzione di Excel ARROTONDA è utile per le elaborazioni contabili, poiché consente di ottenere valori con un preciso numero di decimali. Attenzione a non  confondere il valore visualizzato con il contenuto effettivo di una cella. Per esempio, inserendo 19,756 in Al è possibile ottenere la visualizzazione a sole due cifre decimali (19,76) ma nei calcoli Excel considererà sempre il valore esatto con tre cifre decimali.
Usando invece: =ARROTONDA(A1;2) il contenuto della cella verrà trasformato a tutti gli effetti in 19,76.

EXCEL: GESTIONE DEL CALENDARIO
Excel consente di gestire le date tramite semplici operazioni algebriche oppure sfruttando funzioni apposite. Con una normale sottrazione è possibile sapere quanti giorni intercorrono tra due date, mentre sommando un numero n a una data Excel restituisce la data corrispondente alla data di partenza più n giorni. . Interessano solo i giorni lavorativi tra d ue date? Si può usare GIORNI.LAVORATIVI. TOT.INTL; che permette anche di impostare eventuali festività o giorni di vacanza, come descritto nella pagina Web dedicata a questa funzione sul sito di Microsoft (http://tinyurl.com/giomilavorativi). Con la funzione GIORNO.LAVORATIVO.INTL si può poi calcolare facilmente la data posteriore di n giorni lavorativi ad una data specificata. Scrivendo per esempio:
=GIORNO . LAVORATIVO.INTL( “13/06/2015” ;234) si ottiene 05/05/2016. Utilizzando una semplice somma Excel avrebbe fornito il risultato 02/ 02/ 2016, dato che avrebbe preso in considerazione anche i giorni festivi.
Per determinare il giorno della settimana che corrisponde ad una data specifica è disponibile GIORNO.SETIIMANA. Questa funzione ha il vantaggio di fornire
un risultato numerico (1 per lunedì, 2 per martedì e così via), che consente ulteriori elaborazioni. Per trasformare il numero nel giorno corrispondente basta
applicare il formato cella Personalizzato impostato a gggg. Tra le altre funzioni che operano sulle date ricordiamo OGGI che visualizza la data del giorno corrente e le analoghe ANNO, MESE, NUM.SETTIMANA e FINE.MESE: quest’ultima restituisce la data dell’ultimo giorno del mese specificato.

EXCEL: LAVORARE CON IL TESTO
Excel_gestione_testoNonostante Excel venga utilizzato prevalentemente per elaborare numeri, offre una serie di interessanti funzioni per la gestione dei contenuti testuali. Per estrapolare una parte di una parola o di un’intera stringa si possono impiegare le funzioni SINISTRA, DESTRA
e STRINGA.ESTRAI. Il loro funzionamento è piuttosto semplice: basta indicare il numero dei caratteri da estrarre e, nel caso d i STRINGA.ESTRAI (il nome inglese MIO- abbreviazione di middle-è probabilmente più esplicativo) anche il punto di partenza. Se per esempio la colonna C contiene una serie di indirizzi nella fo rma CAP Città PR, partendo dal presupposto che il codice di avviamento postale sia sempre di 5 caratteri e la provincia di 2, si possono estrarre con facilità i tre dati . Per il CAP: =SINISTRA(C2;5)
Per la città: =STRINGA. ESTRAI(C2; 7 ;LUNGHEZZA(C2)-6-3) Per la provincia:
=DESTRA(C2;2)
Quando non si conosce il numero dei caratteri da estrarre o la loro posizione all’interno della parola, è possibile farsi aiutare dalle funzioni LUNGHEZZA e TROVA oppure da RICERCA. Per esempio ,se la colonna A contiene una serie di sigle da cui si vogliono estrarre i caratteri compresi tra due marcatori (nel nostro caso 78 e il punto fermo), bisogna trovare innanzitutto la posizione di questi ultimi nel seguente modo: =TROVA(78;A2;1) restituisce la posizione di 78 mentre =TROVA( “.”;A2;1) restituisce quella del punto fermo. Ora, tramite STRINGA.ESTRAI si ottiene quanto desiderato: =STRINGA.ESTRAI(A2;TROVA(78;A2;1)+2;TROVA( ” . N;A2;1)- (TROVA(78 ;A2;1)+2)) Per avere invece solo la parte d i testo successiva a l punto fermo bisogna usare:
=DESTRA(A2;LUNGHEZZA(A2 ) – TROVA(“. “;A2;1))
Tra le altre funzioni interessanti ricordiamo ANNULLA.SPAZ, che elimina eventuali spazi all’inizio o alla fine della stringa di testo (ma non quelli tra due parole) e MAIUSCOLO, MINUSCOLO, MAIUSC.INIZ, che agiscono sulle maiuscole e sulle minuscole in modo analogo al tasto hmzione F3 in Word.

ALLA RICERCA EL DATO PERDUTO
In alcune s ituazioni è necessario estrarre dei dati da un intervallo di celle in base a una determinata chiave di ricerca. Per questa operazione ci si può rivolgere a CERCA.VERT oppure a CONFRONTA, funzione che restituisce la posizione di un elemento all’interno di un determinato range di celle. La sua sintassi è molto semplice: CONFRONTA (chiave di ricerca; range di celle; corrispondenza).

Per Corrispondenza, specificare O se il range non è ordinato e la ricerca deve terminare quando viene trovata la chiave; con 1 la funzione presume che i dati siano in ordine crescente e si ferma se incontra un valore uguale o minore di quello cercato; con -1 Excel presume invece che i dati siano in ordine decrescente e si ferma quando rileva un valore uguale o maggiore a quello cercato.  Questi dati possono essere inseriti manualmente, oppure selezionati da un menu creato con Convalida dati. Per  scoprire in quale riga della colonna A è presente l’azienda indicata bisogna usare: =CONFRONTA(A2;A4:A18;0) per trovare invece la colonna: =CONFRONTA(B2;A4 :H4;0) A questo punto, per individuare un valore di una cella si sfrutta INDICE (matrice; riga; colonna). La formula completa è:
=INDICE(A4 :H18;CONFRONTA(A2; T A4:A18;0);CONFRONTA(B2;A4:H4;0))

FUNZIONE SE
Questa funzione è uno dei pilastri della programmazione di Excel, poiché consente d i eseguire operazioni differenti in base a determinate condizioni. La sintassi è molto semplice: SE( test; [se_vero); [se_falso])
Un esempio potrebbe essere l’assegnazione di un bonus di 1.000 ai dipendenti che guadagnano meno di 50.000 euro. Supponendo che la colonna G contenga lo
stipendio, la formula è: =SE(G2(50000;1000;NN) Se il bonus dipendesse anche dall’anzianità lavorativa (1.000 euro sotto i 3 anni e 2.000 per gli altri)  basterebbe modificare la formula come segue: =SE(G2<50000;SE (F2<3; 1000 ; 2000) ; “”) In pratica, quando la prima condizione è vera viene eseguito anche il test SE(F2<3;1000;2000); allo stesso modo si possono prevedere condizioni aggiuntive.